Infinite certificate chain depth results in OctoRPKI running forever
Priority LOW 34CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
OctoRPKI does not limit the depth of a certificate chain, allowing for a CA to create children in an ad-hoc fashion, thereby making tree traversal never end.
Why it matters now
EPSS 0.00731 54th percentileScored 2026-11-07
Fix Fixed octorpki (Cloudflare): 1.4.0github.com/cloudflare/cfrpki (Go): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloudflare | octorpki | before 1.4.0 | 1.4.0 | Patch available | CNA |
| — | github.com/cloudflare/cfrpki (Go) | before 1.4.0 | 1.4.0 | Patch available | GHSA-g5gj-9ggf-9vmq |
- octorpki VendorCloudflare Affected before 1.4.0 Fixed in 1.4.0 Patch available CNA
- github.com/cloudflare/cfrpki (Go) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-g5gj-9ggf-9vmq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudflare:octorpki:*:*:*:*:*:*:*:* | before 1.3.0 | Vulnerable | Cloudflare |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:cloudflare:octorpki:*:*:*:*:*:*:*:* Versions before 1.3.0 Vulnerable ·Cloudflare
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA octorpki (Cloudflare) Fixed in 1.4.0
- Fix · GHSA-g5gj-9ggf-9vmq github.com/cloudflare/cfrpki (Go) Fixed in 1.4.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cloudflare octorpki 1.4.0
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2021-02820 NUL character in ROA causes OctoRPKI to crashPriority LOW 35
- TI-2021-02821 Misconfigured IP address field in ROA leads to OctoRPKI crashPriority LOW 31
- TI-2021-02822 OctoRPKI crashes when processing GZIP bomb returned via malicious repositoryPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2021-3908
- 2026-10-03 Alias added: GHSA-g5gj-9ggf-9vmq
References
More Cloudflare Octorpki vulnerabilities
- TI-2021-02817 Arbitrary filepath traversal via URI injection CVSS 3.1CRITICAL 9.8
- TI-2021-02819 Infinite open connection causes OctoRPKI to hang forever CVSS 3.1HIGH 7.5
- TI-2021-02820 NUL character in ROA causes OctoRPKI to crash CVSS 3.1HIGH 7.5
- TI-2021-02693 OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values CVSS 3.1HIGH 7.5
- TI-2021-02875 Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki CVSS 3.1HIGH 7.5
- TI-2022-03327 OctoRPKI crash when maximum iterations number is reached CVSS 3.1HIGH 7.5
Sources
- CVE-2021-3908 · CVE Program
- CVE-2021-3908 · NVD
- FIRST EPSS
- GHSA-g5gj-9ggf-9vmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences