WooCommerce Dynamic Pricing and Discounts <= 2.4.1 - Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WooCommerce Dynamic Pricing and Discounts plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.4.1. This is due to missing sanitization on the settings imported via the import() function. This makes it possible for unauthenticated attackers to import a settings file containing malicious JavaScript that would execute when an administrator accesses the settings area of the site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RightPress | WooCommerce Dynamic Pricing and Discounts | before 2.4.2 | 2.4.2 | Patch available | CNA |
- WooCommerce Dynamic Pricing and Discounts VendorRightPress Affected before 2.4.2 Fixed in 2.4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rightpress:woocommerce_dynamic_pricing_and_discounts:*:*:*:*:*:wordpress:*:* | up to 2.4.1 | Vulnerable | RightPress |
- cpe:2.3:a:rightpress:woocommerce_dynamic_pricing_and_discounts:*:*:*:*:*:wordpress:*:* Versions up to 2.4.1 Vulnerable ·RightPress
Remediation
- Fix · CNA WooCommerce Dynamic Pricing and Discounts (RightPress) Fixed in 2.4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4372
- 2026-10-03 Alias added: GHSA-h2r8-43hj-47vm
References
Sources
- CVE-2021-4372 · CVE Program
- CVE-2021-4372 · NVD
- FIRST EPSS
- GHSA-h2r8-43hj-47vm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences