Social Warfare <= 3.5.2 - Remote Code Execution
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
The Social Warfare plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 3.5.2 via the 'swp_url' parameter. This allows attackers to execute code on the server.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01923 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Social Sharing Plugin – Social Warfare (warfareplugins): 3.5.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| warfareplugins | Social Sharing Plugin – Social Warfare | before 3.5.3 | 3.5.3 | Patch available | CNA |
- Social Sharing Plugin – Social Warfare Vendorwarfareplugins Affected before 3.5.3 Fixed in 3.5.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:warfareplugins:social_warfare:*:*:*:*:*:wordpress:*:* | before 3.5.3 | Vulnerable | warfareplugins |
- cpe:2.3:a:warfareplugins:social_warfare:*:*:*:*:*:wordpress:*:* Versions before 3.5.3 Vulnerable ·warfareplugins
Remediation
- Fix · CNA Social Sharing Plugin – Social Warfare (warfareplugins) Fixed in 3.5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4434
- 2026-10-03 Alias added: GHSA-6gjp-6pv7-w558
References
More warfareplugins Social Warfare vulnerabilities
- TI-2019-07343 The social-warfare plugin before 3.5.3 for WordPress has stored XSS via the… KEVCVSS 3.1MEDIUM 6.1
- TI-2023-04458 Social Sharing Plugin - Social Warfare <= 4.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
- TI-2023-00383 Social Warfare <= 4.3.0 - Missing Authorization CVSS 3.1MEDIUM 5.4
- TI-2023-00384 Social Warfare <= 4.3.1 - Cross-Site Request Forgery CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-4434 · CVE Program
- CVE-2021-4434 · NVD
- FIRST EPSS
- GHSA-6gjp-6pv7-w558 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences