Google Language Translator <= 6.0.9 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Google Language Translator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via multiple parameters in versions up to, and including, 6.0.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Specifically affects users with older browsers that lack proper URL encoding support.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| edo888 | Translate WordPress – Google Language Translator | before 6.0.10 | 6.0.10 | Patch available | CNA |
- Translate WordPress – Google Language Translator Vendoredo888 Affected before 6.0.10 Fixed in 6.0.10 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gtranslate:google_language_translator:*:*:*:*:*:wordpress:*:* | up to 6.0.9 | Vulnerable | Gtranslate |
- cpe:2.3:a:gtranslate:google_language_translator:*:*:*:*:*:wordpress:*:* Versions up to 6.0.9 Vulnerable ·Gtranslate
Remediation
- Fix · CNA Translate WordPress – Google Language Translator (edo888) Fixed in 6.0.10
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4452
- 2026-10-03 Alias added: GHSA-w6f8-pq6h-gwxj
References
More edo888 vulnerabilities
- TI-2023-27561 WordPress Translate WordPress – Google Language Translator plugin <= 6.0.19 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-4452 · CVE Program
- CVE-2021-4452 · NVD
- FIRST EPSS
- GHSA-w6f8-pq6h-gwxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences