Read the docs

Gtranslate

Records9All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

Gtranslate records in CISA KEV

No Gtranslate vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

9 records

Priority MEDIUM 55

The Translate WordPress with GTranslate WordPress plugin before 3.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.0047 Published 2023-09-25 Fixed in 3.0.4
Priority LOW 39

The Translate WordPress with GTranslate WordPress plugin before 2.9.9 does not have CSRF check in some files, and write debug data such as user's cookies in a publicly accessible file if a specific parameter is used when…

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00612 Published 2022-03-28 Fixed in 2.9.9 CWE-352
Priority LOW 32

The Google Language Translator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via multiple parameters in versions up to, and including, 6.0.9 due to insufficient input sanitization and output escapi…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00513 Published 2024-10-16 Fixed in 6.0.10 CWE-79
Priority LOW 30

In the Pro and Enterprise versions of GTranslate < 2.8.65, the gtranslate_request_uri_var function runs at the top of all pages and echoes out the contents of $_SERVER['REQUEST_URI'].

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01565 Published 2021-07-30 Fixed in 2.8.65 CWE-116
Priority LOW 23

The Translate WordPress with GTranslate WordPress plugin before 2.9.7 does not sanitise and escape the body parameter in the url_addon/gtranslate-email.php file before outputting it back in the page, leading to a Reflect…

CVSS 3.1MEDIUM 4.7 Network No auth User interaction EPSS 0.00752 Published 2022-02-07 Fixed in 2.9.7 CWE-79
Priority LOW 23

The Translate WordPress – Google Language Translator WordPress plugin before 6.0.12 does not sanitise and escape some of its settings before outputting it in various pages, allowing high privilege users to perform Cross-…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00676 Published 2021-11-08 Fixed in 6.0.12 CWE-79
Open these records in search →