Regular expression Denial of Service in Markdown plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
CKEditor 5 is an open source rich text editor framework with a modular architecture. The CKEditor 5 Markdown plugin (@ckeditor/ckeditor5-markdown-gfm) before version 25.0.0 has a regex denial of service (ReDoS) vulnerability. The vulnerability allowed to abuse link recognition regular expression, which could cause a significant performance drop resulting in browser tab freeze. It affects all users using CKEditor 5 Markdown plugin at version <= 24.0.0. The problem has been recognized and patched. The fix will be available in version 25.0.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ckeditor | ckeditor5 | before 25.0.0 | 25.0.0 | Patch available | CNA |
| — | @ckeditor/ckeditor5-markdown-gfm (npm) | before 25.0.0 | 25.0.0 | Patch available | GHSA-hgmg-hhc8-g5wr |
- ckeditor5 Vendorckeditor Affected before 25.0.0 Fixed in 25.0.0 Patch available CNA
- @ckeditor/ckeditor5-markdown-gfm (npm) Vendor— Affected before 25.0.0 Fixed in 25.0.0 Patch available GHSA-hgmg-hhc8-g5wr
Remediation
- Fix · CNA ckeditor5 (ckeditor) Fixed in 25.0.0
- Fix · GHSA-hgmg-hhc8-g5wr @ckeditor/ckeditor5-markdown-gfm (npm) Fixed in 25.0.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21254
- 2026-10-03 Alias added: GHSA-hgmg-hhc8-g5wr
References
Advisory 3
More Ckeditor5 vulnerabilities
- TI-2025-37971 A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular… CVSS 3.1MEDIUM 5.4
- TI-2026-22628 CKEditor: Cross-site scripting (XSS) in the HTML Support package CVSS 3.1MEDIUM 6.4
- TI-2024-30632 CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package CVSS 4.0MEDIUM 5.1
Sources
- CVE-2021-21254 · CVE Program
- CVE-2021-21254 · NVD
- FIRST EPSS
- GHSA-hgmg-hhc8-g5wr · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21254 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences