CKEditor 5 has Cross-site Scripting vulnerability in the clipboard package
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ckeditor | ckeditor5 | 40.0.0 to before 43.1.1 | 43.1.1 | Patch available | CNA |
| — | ckeditor5 (npm) | 40.0.0 to before 43.1.1 | 43.1.1 | Patch available | GHSA-rgg8-g5x8-wr9v |
| — | @ckeditor/ckeditor5-clipboard (npm) | 40.0.0 to before 43.1.1 | 43.1.1 | Patch available | GHSA-rgg8-g5x8-wr9v |
- ckeditor5 Vendorckeditor Affected 40.0.0 to before 43.1.1 Fixed in 43.1.1 Patch available CNA
- ckeditor5 (npm) Vendor— Affected 40.0.0 to before 43.1.1 Fixed in 43.1.1 Patch available GHSA-rgg8-g5x8-wr9v
- @ckeditor/ckeditor5-clipboard (npm) Vendor— Affected 40.0.0 to before 43.1.1 Fixed in 43.1.1 Patch available GHSA-rgg8-g5x8-wr9v
Remediation
- Fix · CNA ckeditor5 (ckeditor) Fixed in 43.1.1
- Fix · GHSA-rgg8-g5x8-wr9v ckeditor5 (npm) Fixed in 43.1.1 Advisory →
- Fix · GHSA-rgg8-g5x8-wr9v @ckeditor/ckeditor5-clipboard (npm) Fixed in 43.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45613
- 2026-10-03 Alias added: GHSA-rgg8-g5x8-wr9v
References
More Ckeditor5 vulnerabilities
- TI-2025-37971 A reflected cross-site scripting (XSS) vulnerability in CKeditor v46.1.0 & Angular… CVSS 3.1MEDIUM 5.4
- TI-2021-04357 Regular expression Denial of Service in Markdown plugin CVSS 3.1MEDIUM 6.5
- TI-2026-22628 CKEditor: Cross-site scripting (XSS) in the HTML Support package CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-45613 · CVE Program
- CVE-2024-45613 · NVD
- FIRST EPSS
- GHSA-rgg8-g5x8-wr9v · GitHub Advisory Database · CC BY 4.0
- CVE-2024-45613 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences