Fixes a bug in Zend Framework's Stream HTTP Wrapper
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Magento-lts is a long-term support alternative to Magento Community Edition (CE). In magento-lts versions 19.4.12 and prior and 20.0.8 and prior, there is a vulnerability caused by the unsecured deserialization of an object. A patch in versions 19.4.13 and 20.0.9 was back ported from Zend Framework 3. The vulnerability was assigned CVE-2021-3007 in Zend Framework.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMage | magento-lts | up to 19.4.12; up to 20.0.8 | — | No fix listed | CNA |
| — | openmage/magento-lts (Packagist) | before 19.4.13 | 19.4.13 | Patch available | GHSA-m496-x567-f98c |
| — | openmage/magento-lts (Packagist) | 20.0.0 to before 20.0.9 | 20.0.9 | Patch available | GHSA-m496-x567-f98c |
- magento-lts VendorOpenMage Affected up to 19.4.12; up to 20.0.8 Fixed in — No fix listed CNA
- openmage/magento-lts (Packagist) Vendor— Affected before 19.4.13 Fixed in 19.4.13 Patch available GHSA-m496-x567-f98c
- openmage/magento-lts (Packagist) Vendor— Affected 20.0.0 to before 20.0.9 Fixed in 20.0.9 Patch available GHSA-m496-x567-f98c
Remediation
- Fix · GHSA-m496-x567-f98c openmage/magento-lts (Packagist) Fixed in 19.4.13 Advisory →
- Fix · GHSA-m496-x567-f98c openmage/magento-lts (Packagist) Fixed in 20.0.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21426
- 2026-10-03 Alias added: GHSA-m496-x567-f98c
References
More OpenMage Magento vulnerabilities
- TI-2026-20633 OpenMage LTS's Phar Deserialization leads to Remote Code Execution CVSS 3.1HIGH 8.1
- TI-2026-29239 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution CVSS 4.0HIGH 8.7
- TI-2023-22272 Magento LTS's guest order "protect code" can be brute-forced too easily CVSS 3.1HIGH 7.5
- TI-2026-28925 Missing authorization in OpenMage magento-lts CVSS 4.0MEDIUM 5.3
- TI-2026-20634 OpenMage LTS has Path Traversal Filter Bypass in Dataflow Module CVSS 3.1MEDIUM 4.9
- TI-2025-39617 OpenMage is vulnerable to XSS in Admin Notifications CVSS 4.0MEDIUM 4.6
Sources
- CVE-2021-21426 · CVE Program
- CVE-2021-21426 · NVD
- FIRST EPSS
- GHSA-m496-x567-f98c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences