OS command injection in Dell PowerScale OneFS
Priority LOW 29CWE-78Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Dell PowerScale OneFS 8.1.0-9.1.0 contain an improper neutralization of special elements used in an OS command vulnerability. This vulnerability may allow an authenticated user with ISI_PRIV_LOGIN_SSH or ISI_PRIV_LOGIN_CONSOLE privileges to escalate privileges.
Why it matters now
EPSS 0.00272 19th percentileScored 2026-11-07
Fix Fixed PowerScale OneFS (Dell): 9.0.0 / 9.1.0 / 9.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerScale OneFS | before 9.0.0 / 9.1.0 / 9.2.0 | 9.0.0 / 9.1.0 / 9.2.0 | Patch available | CNA |
- PowerScale OneFS VendorDell Affected before 9.0.0 / 9.1.0 / 9.2.0 Fixed in 9.0.0 / 9.1.0 / 9.2.0 Patch available CNA
Remediation
- Fix · CNA PowerScale OneFS (Dell) Fixed in 9.0.0 / 9.1.0 / 9.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21527
- 2026-10-03 Alias added: GHSA-qwv4-2r5r-v9j3
References
More Dell Emc Powerscale Onefs vulnerabilities
- TI-2022-22190 Improper privilege management in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-10097 Dell PowerScale OneFS, versions 8.2.x-9.3.x, contain a predictable seed in pseudo-random… CVSS 3.1CRITICAL 9.8
- TI-2022-06835 Missing brute-force protection in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2021-04595 Improper authentication in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-22189 Improper certificate validation in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
- TI-2022-15270 Insufficiently protected credentials in Dell PowerScale OneFS CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-21527 · CVE Program
- CVE-2021-21527 · NVD
- FIRST EPSS
- GHSA-qwv4-2r5r-v9j3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences