Read the docs
TI-2021-04623 Aliases CVE-2021-21538GHSA-rg74-cg6p-wp8q

Improper authentication in Dell Integrated Dell Remote Access Controller

Priority MEDIUM 46CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.

Summary

Dell EMC iDRAC9 versions 4.40.00.00 and later, but prior to 4.40.10.00, contain an improper authentication vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability to gain access to the virtual console.

Why it matters now

EPSS 0.01499 74th percentileScored 2026-11-07
Fix Fixed Integrated Dell Remote Access Controller (iDRAC) (Dell): 4.40.10.00

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DellIntegrated Dell Remote Access Controller (iDRAC)before 4.40.10.004.40.10.00Patch availableCNA
  • Integrated Dell Remote Access Controller (iDRAC) VendorDell Affected before 4.40.10.00 Fixed in 4.40.10.00 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:o:dell:idrac9_firmware:*:*:*:*:*:*:*:*4.40.00.00 to before 4.40.10.00VulnerableDell
  • cpe:2.3:o:dell:idrac9_firmware:*:*:*:*:*:*:*:* Versions 4.40.00.00 to before 4.40.10.00 Vulnerable ·Dell

Remediation

  • Fix · CNA Integrated Dell Remote Access Controller (iDRAC) (Dell) Fixed in 4.40.10.00

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21538
  2. 2026-10-03 Alias added: GHSA-rg74-cg6p-wp8q

References

  • TI-2020-04396 Stack-based buffer overflow in Dell Integrated Dell Remote Access Controller CVSS 3.1CRITICAL 9.8
  • TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
  • TI-2019-02728 WS-MAN Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2019-02727 Web Interface Authentication Bypass Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2018-01149 iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent. CVSS 3.0HIGH 8.8
  • TI-2018-11252 iDRAC7/iDRAC8/iDRAC9 - Privilege Escalation Vulnerability CVSS 3.0HIGH 8.8
See all 20 →

Sources