Buffer overflow in Dell EMC iDRAC
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
Dell EMC iDRAC6 versions prior to 2.92, iDRAC7/iDRAC8 versions prior to 2.61.60.60, and iDRAC9 versions prior to 3.20.21.20, 3.21.24.22, 3.21.26.22 and 3.23.23.23 contain a stack-based buffer overflow vulnerability. An unauthenticated remote attacker may potentially exploit this vulnerability to crash the webserver or execute arbitrary code on the system with privileges of the webserver by sending specially crafted input data to the affected system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | iDRAC | 2.92 to before 2.92; 2.61.60.60 to before 2.61.60.60; 3.20.21.20 to before 3.20.21.20; 3.21.24.22 to before 3.21.24.22; 3.23.23.23 to before 3.23.23.23; 3.21.26.22 to before 3.21.26.22 | 2.92, 2.61.60.60, 3.20.21.20, 3.21.24.22, 3.23.23.23, 3.21.26.22 | Patch available | CNA |
- iDRAC VendorDell EMC Affected 2.92 to before 2.92; 2.61.60.60 to before 2.61.60.60; 3.20.21.20 to before 3.20.21.20; 3.21.24.22 to before 3.21.24.22; 3.23.23.23 to before 3.23.23.23; 3.21.26.22 to before 3.21.26.22 Fixed in 2.92, 2.61.60.60, 3.20.21.20, 3.21.24.22, 3.23.23.23, 3.21.26.22 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:idrac6_firmware:*:*:*:*:*:*:*:* | before 2.92 | Vulnerable | Dell |
| cpe:2.3:o:dell:idrac7_firmware:*:*:*:*:*:*:*:* | before 2.61.60.60 | Vulnerable | Dell |
| cpe:2.3:o:dell:idrac8_firmware:*:*:*:*:*:*:*:* | before 2.61.60.60 | Vulnerable | Dell |
| cpe:2.3:o:dell:idrac9_firmware:*:*:*:*:*:*:*:* | before 3.20.21.20 | Vulnerable | Dell |
- cpe:2.3:o:dell:idrac6_firmware:*:*:*:*:*:*:*:* Versions before 2.92 Vulnerable ·Dell
- cpe:2.3:o:dell:idrac7_firmware:*:*:*:*:*:*:*:* Versions before 2.61.60.60 Vulnerable ·Dell
- cpe:2.3:o:dell:idrac8_firmware:*:*:*:*:*:*:*:* Versions before 2.61.60.60 Vulnerable ·Dell
- cpe:2.3:o:dell:idrac9_firmware:*:*:*:*:*:*:*:* Versions before 3.20.21.20 Vulnerable ·Dell
Remediation
- Fix · CNA iDRAC (Dell EMC) Fixed in 2.92, 2.61.60.60, 3.20.21.20, 3.21.24.22, 3.23.23.23, 3.21.26.22
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3705
- 2026-10-03 Alias added: GHSA-76h7-m86v-wq78
References
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
Sources
- CVE-2019-3705 · CVE Program
- CVE-2019-3705 · NVD
- FIRST EPSS
- GHSA-76h7-m86v-wq78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences