Read the docs
TI-2021-04684 Aliases CVE-2021-21604GHSA-qv6f-rcv6-6q3x

Deserialization of untrusted data in Jenkins

Priority LOW 38CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.

Summary

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier allows attackers with permission to create or configure various objects to inject crafted content into Old Data Monitor that results in the instantiation of potentially unsafe objects once discarded by an administrator.

Why it matters now

EPSS 0.01697 77th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.263.2, 2.275Red Hat: 4 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkinsup to 2.274; up to LTS 2.263.1—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.263.22.263.2Patch availableGHSA-qv6f-rcv6-6q3x
—org.jenkins-ci.main:jenkins-core (Maven)2.264 to before 2.2752.275Patch availableGHSA-qv6f-rcv6-6q3x
  • Jenkins VendorJenkins Affected up to 2.274; up to LTS 2.263.1 Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.263.2 Fixed in 2.263.2 Patch available GHSA-qv6f-rcv6-6q3x
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.264 to before 2.275 Fixed in 2.275 Patch available GHSA-qv6f-rcv6-6q3x

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.263.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.274VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.263.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.274 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-qv6f-rcv6-6q3x org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.263.2 Advisory →
  • Fix · GHSA-qv6f-rcv6-6q3x org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.275 Advisory →

Red Hat 4 advisories

  • RHSA-2021:2437 Released 2021-07-27 · Red Hat rating Moderate
    OpenShift Container Platform 4.8.2 packages and security update
    • Red Hat OpenShift Container Platform 4.8 afterburn-5.0.0-1.rhaos4.8.el8, atomic-openshift-service-idler-4.8.0-202106281541.p0.git.39cfc66.assembly.stream.el8, butane-0.12.1-1.rhaos4.8.el8 +47
  • RHSA-2021:0637 Released 2021-03-03 · Red Hat rating Important
    OpenShift Container Platform 3.11.394 bug fix and security update
    • Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1612862361-1.el7, jenkins-2.263.3.1612433584-1.el7, python-rsa-4.5-3.el7 +1
  • RHSA-2021:0429 Released 2021-03-03 · Red Hat rating Important
    OpenShift Container Platform 4.5.33 packages and security update
    • Red Hat OpenShift Container Platform 4.5 conmon-2:2.0.21-1.rhaos4.5.el7, conmon-2:2.0.21-1.rhaos4.5.el8, jenkins-2.263.3.1612434332-1.el7 +12
Show 1 more Red Hat advisories
  • RHSA-2021:0423 Released 2021-02-17 · Red Hat rating Important
    OpenShift Container Platform 4.6.17 security and packages update
    • Red Hat OpenShift Container Platform 4.6 jenkins-2.263.3.1612434510-1.el8

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11Fixed RHSA-2021:0637
Red Hat OpenShift Container Platform 4.5Fixed RHSA-2021:0429
Red Hat OpenShift Container Platform 4.6Fixed RHSA-2021:0423
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2021:2437
Not affected: 3 products
  • Red Hat Fuse 7
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21604
  2. 2026-10-03 Alias added: GHSA-qv6f-rcv6-6q3x

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources