Cross-site scripting in Jenkins Claim Plugin
Priority LOW 36CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Claim Plugin 2.18.1 and earlier does not escape the user display name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers who are able to control the display names of Jenkins users, either via the security realm, or directly inside Jenkins.
Why it matters now
EPSS 0.0939 95th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:claim (Maven): 2.18.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Claim Plugin | up to 2.18.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:claim (Maven) | before 2.18.2 | 2.18.2 | Patch available | GHSA-48hr-jg4p-w4p4 |
- Jenkins Claim Plugin VendorJenkins Affected up to 2.18.1 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:claim (Maven) Vendor— Affected before 2.18.2 Fixed in 2.18.2 Patch available GHSA-48hr-jg4p-w4p4
Remediation
- Fix · GHSA-48hr-jg4p-w4p4 org.jenkins-ci.plugins:claim (Maven) Fixed in 2.18.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21619
- 2026-10-03 Alias added: GHSA-48hr-jg4p-w4p4
References
Advisory 3
More Jenkins Claim vulnerabilities
- TI-2021-04700 Cross-site request forgery in Jenkins Claim Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2021-21619 · CVE Program
- CVE-2021-21619 · NVD
- FIRST EPSS
- GHSA-48hr-jg4p-w4p4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences