Cross-site request forgery in Jenkins Claim Plugin
Priority LOW 23CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins Claim Plugin 2.18.1 and earlier allows attackers to change claims.
Why it matters now
EPSS 0.01635 76th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:claim (Maven): 2.18.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Claim Plugin | up to 2.18.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:claim (Maven) | before 2.18.2 | 2.18.2 | Patch available | GHSA-4ffq-6g62-j4v4 |
- Jenkins Claim Plugin VendorJenkins Affected up to 2.18.1 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:claim (Maven) Vendor— Affected before 2.18.2 Fixed in 2.18.2 Patch available GHSA-4ffq-6g62-j4v4
Remediation
- Fix · GHSA-4ffq-6g62-j4v4 org.jenkins-ci.plugins:claim (Maven) Fixed in 2.18.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21620
- 2026-10-03 Alias added: GHSA-4ffq-6g62-j4v4
References
More Jenkins Claim vulnerabilities
- TI-2021-04699 Cross-site scripting in Jenkins Claim Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-21620 · CVE Program
- CVE-2021-21620 · NVD
- FIRST EPSS
- GHSA-4ffq-6g62-j4v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences