Read the docs
TI-2021-04720 Aliases CVE-2021-21640GHSA-w2hv-rcqr-2h7r

Jenkins 2.286 and earlier, LTS 2.277.1 and earlier does not properly check that a newly…

Priority LOW 24CWE-240Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

Jenkins 2.286 and earlier, LTS 2.277.1 and earlier does not properly check that a newly created view has an allowed name, allowing attackers with View/Create permission to create views with invalid or already-used names.

Why it matters now

EPSS 0.01905 79th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.277.2, 2.287Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkinsup to 2.286; up to LTS 2.277.1—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.277.22.277.2Patch availableGHSA-w2hv-rcqr-2h7r
—org.jenkins-ci.main:jenkins-core (Maven)2.278 to before 2.2872.287Patch availableGHSA-w2hv-rcqr-2h7r
  • Jenkins VendorJenkins Affected up to 2.286; up to LTS 2.277.1 Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.277.2 Fixed in 2.277.2 Patch available GHSA-w2hv-rcqr-2h7r
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.278 to before 2.287 Fixed in 2.287 Patch available GHSA-w2hv-rcqr-2h7r

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.277.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.286VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.277.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.286 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-w2hv-rcqr-2h7r org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.277.2 Advisory →
  • Fix · GHSA-w2hv-rcqr-2h7r org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.287 Advisory →

Red Hat 2 advisories

  • RHSA-2021:2437 Released 2021-07-27 · Red Hat rating Moderate
    OpenShift Container Platform 4.8.2 packages and security update
    • Red Hat OpenShift Container Platform 4.8 afterburn-5.0.0-1.rhaos4.8.el8, atomic-openshift-service-idler-4.8.0-202106281541.p0.git.39cfc66.assembly.stream.el8, butane-0.12.1-1.rhaos4.8.el8 +47
  • RHSA-2021:1551 Released 2021-05-19 · Red Hat rating Moderate
    OpenShift Container Platform 4.7.11 security and bug fix update
    • Red Hat OpenShift Container Platform 4.7 cri-tools-1.20.0-2.el7, cri-tools-1.20.0-2.el8, jenkins-2.277.3.1620393611-1.el8 +2

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix yet: Fix deferred
Red Hat OpenShift Container Platform 4.7Fixed RHSA-2021:1551
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2021:2437
Not affected: 3 products
  • Red Hat Fuse 7
  • Red Hat OpenShift Container Platform 4.7
  • Red Hat OpenShift Container Platform 4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21640
  2. 2026-10-03 Alias added: GHSA-w2hv-rcqr-2h7r

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources