Incorrect authorization in Jenkins
Priority LOW 24CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
Jenkins 2.299 and earlier, LTS 2.289.1 and earlier allows users to cancel queue items and abort builds of jobs for which they have Item/Cancel permission even when they do not have Item/Read permission.
Why it matters now
EPSS 0.02038 81st percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.289.2, 2.300Red Hat: 1 advisoryRed Hat: 3 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | up to 2.299; up to LTS 2.289.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.289.2 | 2.289.2 | Patch available | GHSA-q4wp-8c99-69pw |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.292 to before 2.300 | 2.300 | Patch available | GHSA-q4wp-8c99-69pw |
- Jenkins VendorJenkins Affected up to 2.299; up to LTS 2.289.1 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.289.2 Fixed in 2.289.2 Patch available GHSA-q4wp-8c99-69pw
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.292 to before 2.300 Fixed in 2.300 Patch available GHSA-q4wp-8c99-69pw
Remediation
- Fix · GHSA-q4wp-8c99-69pw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.289.2 Advisory →
- Fix · GHSA-q4wp-8c99-69pw org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.300 Advisory →
Red Hat 1 advisory
- RHSA-2021:3820 Released 2021-10-19 · Red Hat rating ModerateOpenShift Container Platform 4.8.15 packages and security update
- Red Hat OpenShift Container Platform 4.8 butane-0.12.1-2.rhaos4.8.el8, jenkins-2.289.3.1633554819-1.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 4.6 | Fixed | — |
| Red Hat OpenShift Container Platform 4.7 | Fixed | — |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2021:3820 |
Not affected: 4 products
- Red Hat Fuse 7
- Red Hat OpenShift Container Platform 4.6
- Red Hat OpenShift Container Platform 4.7
- Red Hat OpenShift Container Platform 4.8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21670
- 2026-10-03 Alias added: GHSA-q4wp-8c99-69pw
References
Advisory 3
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-21670 · CVE Program
- CVE-2021-21670 · NVD
- FIRST EPSS
- GHSA-q4wp-8c99-69pw · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21670 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences