Read the docs
TI-2021-04751 Aliases CVE-2021-21671GHSA-4wr9-2xc6-jmg5

Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login.

Priority LOW 36CWE-384Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 3 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-384.

Summary

Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login.

Why it matters now

EPSS 0.01754 78th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.300, 2.289.2Red Hat: 1 advisoryRed Hat: 3 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins2.266 and later; LTS 2.277.1 and later; up to 2.299; up to LTS 2.289.1—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.292 to before 2.3002.300Patch availableGHSA-4wr9-2xc6-jmg5
—org.jenkins-ci.main:jenkins-core (Maven)before 2.289.22.289.2Patch availableGHSA-4wr9-2xc6-jmg5
  • Jenkins VendorJenkins Affected 2.266 and later; LTS 2.277.1 and later; up to 2.299; up to LTS 2.289.1 Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.292 to before 2.300 Fixed in 2.300 Patch available GHSA-4wr9-2xc6-jmg5
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.289.2 Fixed in 2.289.2 Patch available GHSA-4wr9-2xc6-jmg5

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*2.266 to before 2.300VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*2.277.1 to before 2.289.2VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions 2.266 to before 2.300 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions 2.277.1 to before 2.289.2 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-4wr9-2xc6-jmg5 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.300 Advisory →
  • Fix · GHSA-4wr9-2xc6-jmg5 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.289.2 Advisory →

Red Hat 1 advisory

  • RHSA-2021:3820 Released 2021-10-19 · Red Hat rating Moderate
    OpenShift Container Platform 4.8.15 packages and security update
    • Red Hat OpenShift Container Platform 4.8 butane-0.12.1-2.rhaos4.8.el8, jenkins-2.289.3.1633554819-1.el8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 4.6Fixed—
Red Hat OpenShift Container Platform 4.7Fixed—
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2021:3820
Not affected: 4 products
  • Red Hat Fuse 7
  • Red Hat OpenShift Container Platform 4.6
  • Red Hat OpenShift Container Platform 4.7
  • Red Hat OpenShift Container Platform 4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21671
  2. 2026-10-03 Alias added: GHSA-4wr9-2xc6-jmg5

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources