Jenkins 2.314 and earlier, LTS 2.303.1 and earlier accepts names of jobs and other…
Priority LOW 22CWE-42Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins 2.314 and earlier, LTS 2.303.1 and earlier accepts names of jobs and other entities with a trailing dot character, potentially replacing the configuration and data of other entities on Windows.
Why it matters now
EPSS 0.00999 62nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.315, 2.303.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | up to 2.314; up to LTS 2.303.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.304 to before 2.315 | 2.315 | Patch available | GHSA-6q4g-84f3-mw74 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.303.2 | 2.303.2 | Patch available | GHSA-6q4g-84f3-mw74 |
- Jenkins VendorJenkins Affected up to 2.314; up to LTS 2.303.1 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.304 to before 2.315 Fixed in 2.315 Patch available GHSA-6q4g-84f3-mw74
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.303.2 Fixed in 2.303.2 Patch available GHSA-6q4g-84f3-mw74
Remediation
- Fix · GHSA-6q4g-84f3-mw74 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.315 Advisory →
- Fix · GHSA-6q4g-84f3-mw74 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.303.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21682
- 2026-10-03 Alias added: GHSA-6q4g-84f3-mw74
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2021-21682 · CVE Program
- CVE-2021-21682 · NVD
- FIRST EPSS
- GHSA-6q4g-84f3-mw74 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences