Incorrect URL validation in FILTER_VALIDATE_URL
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 4 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | 7.3.x to before 7.3.29; 7.4.x to before 7.4.21; 8.0.X to before 8.0.8 | 7.3.29, 7.4.21, 8.0.8 | Patch available | CNA |
- PHP VendorPHP Group Affected 7.3.x to before 7.3.29; 7.4.x to before 7.4.21; 8.0.X to before 8.0.8 Fixed in 7.3.29, 7.4.21, 8.0.8 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 7.3.0 to before 7.3.29; 7.4.0 to before 7.4.21; 8.0.0 to before 8.0.8 | Vulnerable | PHP |
| cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:oracle:sd-wan_aware:8.2:*:*:*:*:*:*:* | 8.2 | Vulnerable | Oracle |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 7.3.0 to before 7.3.29; 7.4.0 to before 7.4.21; 8.0.0 to before 8.0.8 Vulnerable ·PHP
- cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:oracle:sd-wan_aware:8.2:*:*:*:*:*:*:* Versions 8.2 Vulnerable ·Oracle
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 7.3.29, 7.4.21, 8.0.8
Red Hat 2 advisories
- RHSA-2022:1935 Released 2022-05-10 · Red Hat rating Moderatephp:7.4 security update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.3.0+6678+b09f589e.noarch::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.aarch64::php:7.4, libzip-1.6.1-1.module+el8.3.0+6678+b09f589e.ppc64le::php:7.4 +47
- RHSA-2021:2992 Released 2021-08-03 · Red Hat rating Moderaterh-php73-php security, bug fix, and enhancement update
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-php73-php-7.3.29-1.el7, rh-php73-php-bcmath-7.3.29-1.el7, rh-php73-php-cli-7.3.29-1.el7 +26
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PHP 7.3.29, 7.4.21, 8.0.8
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-04784 Multiple vulnerabilities in Firebird client extensionPriority LOW 30
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:1935 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2021:2992 |
| Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.7) | Fixed | RHSA-2021:2992 |
| Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2021:2992 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-21705
- 2026-10-03 Alias added: GHSA-rxcr-7xjm-f9c9
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2021-21705 · CVE Program
- CVE-2021-21705 · NVD
- FIRST EPSS
- GHSA-rxcr-7xjm-f9c9 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-21705 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences