Read the docs
TI-2021-05104 Aliases CVE-2021-22112GHSA-gq28-h5vg-8prx

Improper privilege management in Spring Security

Priority MEDIUM 44CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.

Summary

Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to save the SecurityContext if it is changed more than once in a single request.A malicious user cannot cause the bug to happen (it must be programmed in). However, if the application's intent is to only allow the user to run with elevated privileges in a small portion of the application, the bug can be leveraged to extend those privileges to the rest of the application.

Why it matters now

EPSS 0.03286 88th percentileScored 2026-11-07
Fix Fixed org.springframework.security:spring-security-bom (Maven): 5.4.4, 5.3.8, 5.2.9org.springframework.security:spring-security-web (Maven): 5.4.4, 5.3.8, 5.2.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Spring Security5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE—No fix listedCNA
—org.springframework.security:spring-security-bom (Maven)5.4.0 to before 5.4.45.4.4Patch availableGHSA-gq28-h5vg-8prx
—org.springframework.security:spring-security-bom (Maven)5.3.0 to before 5.3.85.3.8Patch availableGHSA-gq28-h5vg-8prx
—org.springframework.security:spring-security-bom (Maven)before 5.2.95.2.9Patch availableGHSA-gq28-h5vg-8prx
—org.springframework.security:spring-security-web (Maven)5.4.0 to before 5.4.45.4.4Patch availableGHSA-gq28-h5vg-8prx
—org.springframework.security:spring-security-web (Maven)5.3.0 to before 5.3.85.3.8Patch availableGHSA-gq28-h5vg-8prx
—org.springframework.security:spring-security-web (Maven)before 5.2.95.2.9Patch availableGHSA-gq28-h5vg-8prx
  • Spring Security Vendor— Affected 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE Fixed in — No fix listed CNA
  • org.springframework.security:spring-security-bom (Maven) Vendor— Affected 5.4.0 to before 5.4.4 Fixed in 5.4.4 Patch available GHSA-gq28-h5vg-8prx
  • org.springframework.security:spring-security-bom (Maven) Vendor— Affected 5.3.0 to before 5.3.8 Fixed in 5.3.8 Patch available GHSA-gq28-h5vg-8prx
  • org.springframework.security:spring-security-bom (Maven) Vendor— Affected before 5.2.9 Fixed in 5.2.9 Patch available GHSA-gq28-h5vg-8prx
  • org.springframework.security:spring-security-web (Maven) Vendor— Affected 5.4.0 to before 5.4.4 Fixed in 5.4.4 Patch available GHSA-gq28-h5vg-8prx
  • org.springframework.security:spring-security-web (Maven) Vendor— Affected 5.3.0 to before 5.3.8 Fixed in 5.3.8 Patch available GHSA-gq28-h5vg-8prx
  • org.springframework.security:spring-security-web (Maven) Vendor— Affected before 5.2.9 Fixed in 5.2.9 Patch available GHSA-gq28-h5vg-8prx

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:pivotal_software:spring_security:*:*:*:*:*:*:*:*before 5.2.9; 5.3.0 to before 5.3.8VulnerableSpring by Pivotal
cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:*5.4.0 to before 5.4.4VulnerableVMware
cpe:2.3:a:oracle:communications_element_manager:*:*:*:*:*:*:*:*8.2.0 – 8.2.4.0VulnerableOracle
cpe:2.3:a:oracle:communications_interactive_session_recorder:6.3:*:*:*:*:*:*:*6.3VulnerableOracle
cpe:2.3:a:oracle:communications_interactive_session_recorder:6.4:*:*:*:*:*:*:*6.4VulnerableOracle
cpe:2.3:a:oracle:communications_unified_inventory_management:7.4.1:*:*:*:*:*:*:*7.4.1VulnerableOracle
cpe:2.3:a:oracle:hospitality_cruise_shipboard_property_management_system:20.1.0:*:*:*:*:*:*:*20.1.0VulnerableOracle
cpe:2.3:a:oracle:insurance_policy_administration:11.2.0:*:*:*:*:*:*:*11.2.0VulnerableOracle
cpe:2.3:a:oracle:insurance_policy_administration:11.3.0:*:*:*:*:*:*:*11.3.0VulnerableOracle
cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:*up to 8.0.25VulnerableOracle
  • cpe:2.3:a:pivotal_software:spring_security:*:*:*:*:*:*:*:* Versions before 5.2.9; 5.3.0 to before 5.3.8 Vulnerable ·Spring by Pivotal
  • cpe:2.3:a:vmware:spring_security:*:*:*:*:*:*:*:* Versions 5.4.0 to before 5.4.4 Vulnerable ·VMware
  • cpe:2.3:a:oracle:communications_element_manager:*:*:*:*:*:*:*:* Versions 8.2.0 – 8.2.4.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:communications_interactive_session_recorder:6.3:*:*:*:*:*:*:* Versions 6.3 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:communications_interactive_session_recorder:6.4:*:*:*:*:*:*:* Versions 6.4 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:communications_unified_inventory_management:7.4.1:*:*:*:*:*:*:* Versions 7.4.1 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:hospitality_cruise_shipboard_property_management_system:20.1.0:*:*:*:*:*:*:* Versions 20.1.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:insurance_policy_administration:11.2.0:*:*:*:*:*:*:* Versions 11.2.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:insurance_policy_administration:11.3.0:*:*:*:*:*:*:* Versions 11.3.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:* Versions up to 8.0.25 Vulnerable ·Oracle

Remediation

  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-bom (Maven) Fixed in 5.4.4 Advisory →
  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-bom (Maven) Fixed in 5.3.8 Advisory →
  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-bom (Maven) Fixed in 5.2.9 Advisory →
  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-web (Maven) Fixed in 5.4.4 Advisory →
  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-web (Maven) Fixed in 5.3.8 Advisory →
  • Fix · GHSA-gq28-h5vg-8prx org.springframework.security:spring-security-web (Maven) Fixed in 5.2.9 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 3 products
  • Red Hat Fuse 7
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-22112
  2. 2026-10-03 Alias added: GHSA-gq28-h5vg-8prx

References

Other 23

Sources