Read the docs
TI-2021-05122 Aliases CVE-2021-22132GHSA-5fvx-2jj3-6mff

Insufficiently protected credentials in Elasticsearch

Priority LOW 25CWE-522Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Partial Red Hat: 2 fixed, 4 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-522.

Summary

Elasticsearch versions 7.7.0 to 7.10.1 contain an information disclosure flaw in the async search API. Users who execute an async search will improperly store the HTTP headers. An Elasticsearch user with the ability to read the .tasks index could obtain sensitive request headers of other users in the cluster. This issue is fixed in Elasticsearch 7.10.2

Why it matters now

EPSS 0.01222 68th percentileScored 2026-11-07
Fix Partial org.elasticsearch:elasticsearch (Maven): 7.10.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 4 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElasticElasticsearch7.7.0 to 7.10.1—No fix listedCNA
—org.elasticsearch:elasticsearch (Maven)7.7.0 to before 7.10.27.10.2Patch availableGHSA-5fvx-2jj3-6mff
  • Elasticsearch VendorElastic Affected 7.7.0 to 7.10.1 Fixed in — No fix listed CNA
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.7.0 to before 7.10.2 Fixed in 7.10.2 Patch available GHSA-5fvx-2jj3-6mff

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:*7.7.0 to before 7.10.2VulnerableElastic
cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.8.0:*:*:*:*:*:*:*1.8.0VulnerableOracle
  • cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions 7.7.0 to before 7.10.2 Vulnerable ·Elastic
  • cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.8.0:*:*:*:*:*:*:* Versions 1.8.0 Vulnerable ·Oracle

Remediation

  • Fix · GHSA-5fvx-2jj3-6mff org.elasticsearch:elasticsearch (Maven) Fixed in 7.10.2 Advisory →

Red Hat 2 advisories

  • RHSA-2022:6407 Released 2022-09-09 · Red Hat rating Moderate
    Red Hat Integration Camel-K 1.8 security update
    • RHAF Camel-K 1.8
  • RHSA-2022:5606 Released 2022-07-19 · Red Hat rating Moderate
    Red Hat Integration Camel Extensions for Quarkus 2.7 security update
    • RHINT Camel-Q 2.7

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Decision Manager 7AffectedNo fix planned: Will not fix
Red Hat Fuse 7AffectedNo fix yet: Fix deferred
Red Hat JBoss Fuse 6AffectedNo fix planned: Out of support scope
Red Hat Process Automation 7AffectedNo fix planned: Will not fix
RHAF Camel-K 1.8Fixed RHSA-2022:6407
RHINT Camel-Q 2.7Fixed RHSA-2022:5606
Not affected: 3 products
  • Red Hat Integration Camel Quarkus 1
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-22132
  2. 2026-10-03 Alias added: GHSA-5fvx-2jj3-6mff

References

  • TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
  • TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
  • TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
  • TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
  • TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
See all 90 →

Sources