Read the docs
TI-2021-05127 Aliases CVE-2021-22137GHSA-hr65-qq6p-87r4

Information disclosure in Elasticsearch

Priority LOW 26CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 2 fixed, 4 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.

Why it matters now

EPSS 0.01187 68th percentileScored 2026-11-07
Fix Partial org.elasticsearch:elasticsearch (Maven): 7.11.2, 6.8.15Red Hat: 2 advisoriesRed Hat: 2 fixed, 4 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ElasticElasticsearchbefore 7.11.2 and 6.8.15—No fix listedCNA
—org.elasticsearch:elasticsearch (Maven)7.11.0 to before 7.11.27.11.2Patch availableGHSA-hr65-qq6p-87r4
—org.elasticsearch:elasticsearch (Maven)before 6.8.156.8.15Patch availableGHSA-hr65-qq6p-87r4
  • Elasticsearch VendorElastic Affected before 7.11.2 and 6.8.15 Fixed in — No fix listed CNA
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected 7.11.0 to before 7.11.2 Fixed in 7.11.2 Patch available GHSA-hr65-qq6p-87r4
  • org.elasticsearch:elasticsearch (Maven) Vendor— Affected before 6.8.15 Fixed in 6.8.15 Patch available GHSA-hr65-qq6p-87r4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:*before 6.8.15; 7.11.0 to before 7.11.2VulnerableElastic
  • cpe:2.3:a:elastic:elasticsearch:*:*:*:*:*:*:*:* Versions before 6.8.15; 7.11.0 to before 7.11.2 Vulnerable ·Elastic

Remediation

  • Fix · GHSA-hr65-qq6p-87r4 org.elasticsearch:elasticsearch (Maven) Fixed in 7.11.2 Advisory →
  • Fix · GHSA-hr65-qq6p-87r4 org.elasticsearch:elasticsearch (Maven) Fixed in 6.8.15 Advisory →

Red Hat 2 advisories

  • RHSA-2022:6407 Released 2022-09-09 · Red Hat rating Moderate
    Red Hat Integration Camel-K 1.8 security update
    • RHAF Camel-K 1.8
  • RHSA-2022:5606 Released 2022-07-19 · Red Hat rating Moderate
    Red Hat Integration Camel Extensions for Quarkus 2.7 security update
    • RHINT Camel-Q 2.7

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Decision Manager 7AffectedNo fix yet: Fix deferred
Red Hat Fuse 7AffectedNo fix yet: Fix deferred
Red Hat JBoss Fuse 6AffectedNo fix planned: Out of support scope
Red Hat Process Automation 7AffectedNo fix yet: Fix deferred
RHAF Camel-K 1.8Fixed RHSA-2022:6407
RHINT Camel-Q 2.7Fixed RHSA-2022:5606
Not affected: 4 products
  • Logging Subsystem for Red Hat OpenShift
  • Red Hat Integration Camel Quarkus 1
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-22137
  2. 2026-10-03 Alias added: GHSA-hr65-qq6p-87r4

References

  • TI-2015-01295 The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-02491 The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which… KEVCVSS 3.1HIGH 8.1
  • TI-2023-15037 Elasticsearch StackOverflow vulnerability CVSS 3.1HIGH 7.5
  • TI-2021-05135 Information disclosure in Elasticsearch CVSS 3.1MEDIUM 6.5
  • TI-2021-05136 All versions of Elastic Cloud Enterprise has the Elasticsearch “anonymous” user enabled… CVSS 3.1HIGH 7.5
  • TI-2015-04530 Elasticsearch before 1.6.1 allows remote attackers to execute arbitrary code via… CVSS 3.0CRITICAL 9.8
See all 90 →

Sources