Read the docs
TI-2021-05522 Aliases CVE-2021-22568

Dart - Publishing to third-party package repositories may expose pub.dev credentials

Priority MEDIUM 40CWE-255Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · High · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

When using the dart pub publish command to publish a package to a third-party package server, the request would be authenticated with an oauth2 access_token that is valid for publishing on pub.dev. Using these obtained credentials, an attacker can impersonate the user on pub.dev. We recommend upgrading past https://github.com/dart-lang/sdk/commit/d787e78d21e12ec1ef712d229940b1172aafcdf8 or beyond version 2.15.0

Why it matters now

EPSS 0.00937 61st percentileScored 2026-11-07
Fix Fixed Dart SDK (Google LLC): 2.15.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
GoogleDart SDKbefore 2.15.02.15.0Patch availableCNA
  • Dart SDK VendorGoogle Affected before 2.15.0 Fixed in 2.15.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dart:dart_software_development_kit:*:*:*:*:*:*:*:*before 2.15.0VulnerableDart
  • cpe:2.3:a:dart:dart_software_development_kit:*:*:*:*:*:*:*:* Versions before 2.15.0 Vulnerable ·Dart

Remediation

  • Fix · CNA Dart SDK (Google LLC) Fixed in 2.15.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-22568

References

  • TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
  • TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
  • TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
  • TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
  • TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
See all 17247 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences