Priority MEDIUM 52
Buffer overflow in the ActiveX control (DartFtp.dll) in Dart Communications PowerTCP FTP for ActiveX 2.0.2 0 allows remote attackers to execute arbitrary code via a long SecretKey property.
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.1011 · Published 2008-10-21 · No fix listed CWE-119
Priority MEDIUM 51
The implementation of backslash parsing in the Dart URI class for versions prior to 2.18 and Flutter versions prior to 3.30 differs from the WhatWG URL standards.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01164 · Published 2022-10-27 · Fixed in 2.18.2, 3.3.3 CWE-20
Priority MEDIUM 50
Buffer overflow in the Dart Communications PowerTCP ZIP Compression ActiveX control in DartZip.dll 1.8.5.3, when Internet Explorer 6 is used, allows user-assisted remote attackers to execute arbitrary code via a long fir…
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.07173 · Published 2007-05-24 · No fix listed CWE-119
Priority MEDIUM 48
Buffer overflow in a certain ActiveX control in DartZipLite.dll 1.8.5.3 in Dart ZipLite Compression for ActiveX allows user-assisted remote attackers to execute arbitrary code via a long first argument to the QuickZip fu…
CVSS 2.0HIGH 9.3· Network · No auth · Interaction — · EPSS 0.04774 · Published 2007-05-24 · No fix listed CWE-119
Priority MEDIUM 42
NULL Pointer Dereference in PowerTCP WebServer for ActiveX 1.9.2 and earlier allows remote attackers to cause a denial of service (application crash) via a crafted HTTP request.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.06603 · Published 2020-01-23 · No fix listed CWE-476
Priority MEDIUM 40
When using the dart pub publish command to publish a package to a third-party package server, the request would be authenticated with an oauth2 access_token that is valid for publishing on pub.dev.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00937 · Published 2021-12-09 · Fixed in 2.15.0 CWE-255
Priority LOW 31
Dart SDK contains the HTTPClient in dart:io library whcih includes authorization headers when handling cross origin redirects.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00998 · Published 2022-02-18 · Fixed in 2.16.0 CWE-305
Priority LOW 31
An issue was discovered in the http package through 0.12.2 for Dart.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.02155 · Published 2020-12-24 · Fixed in 0.13.3 CWE-74
Priority LOW 29
The Dart and Flutter SDKs provide software development kits for the Dart programming language.
CVSS 4.0MEDIUM 6.6· Network · No auth · No interaction · EPSS 0.00408 · Published 2026-02-25 · Fixed in 3.11.0, 3.41.0 CWE-22
Priority LOW 28
Bad validation logic in the Dart SDK versions prior to 2.12.3 allow an attacker to use an XSS attack via DOM clobbering.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00681 · Published 2021-04-22 · Fixed in 2.12.3 CWE-79
Priority LOW 28
A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00617 · Published 2023-04-10 · No fix listed CWE-79
Priority LOW 27
An improper HTML sanitization in Dart versions up to and including 2.7.1 and dev versions 2.8.0-dev.16.0, allows an attacker leveraging DOM Clobbering techniques to skip the sanitization and inject custom html/javascript…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00324 · Published 2020-03-26 · No fix listed CWE-79
Priority LOW 27
Stack consumption vulnerability in dartwebserver.dll 1.9 and earlier, as used in Dart PowerTCP WebServer for ActiveX and other products, allows remote attackers to cause a denial of service (daemon crash) via a long requ…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.02327 · Published 2012-10-04 · No fix listed CWE-119
Priority LOW 22
Bidirectional Unicode text can be interpreted and compiled differently than how it appears in editors which can be exploited to get nefarious code passed a code review by appearing benign.
CVSS 3.1MEDIUM 4.6· Network · Low privileges · User interaction · EPSS 0.00618 · Published 2022-01-05 · Fixed in 2.15.0-268.18.beta CWE-284