Cross-site scripting in Pulse Connect Secure
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability in Pulse Connect Secure before 9.1R12 could allow a threat actor to perform a cross-site script attack against an authenticated administrator via an unsanitized web parameter.
Why it matters now
EPSS 0.00848 58th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Pulse Connect Secure | Fixed in 9.1R12 | — | No fix listed | CNA |
- Pulse Connect Secure Vendor— Affected Fixed in 9.1R12 Fixed in — No fix listed CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ivanti:connect_secure:9.1:-:*:*:*:*:*:* | 9.1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r1.0:*:*:*:*:*:* | 9.1 r1.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r10.0:*:*:*:*:*:* | 9.1 r10.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r11.0:*:*:*:*:*:* | 9.1 r11.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r2.0:*:*:*:*:*:* | 9.1 r2.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r3.0:*:*:*:*:*:* | 9.1 r3.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r4.0:*:*:*:*:*:* | 9.1 r4.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r5.0:*:*:*:*:*:* | 9.1 r5.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r6.0:*:*:*:*:*:* | 9.1 r6.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r7.0:*:*:*:*:*:* | 9.1 r7.0 | Vulnerable | Ivanti |
- cpe:2.3:a:ivanti:connect_secure:9.1:-:*:*:*:*:*:* Versions 9.1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r1.0:*:*:*:*:*:* Versions 9.1 r1.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r10.0:*:*:*:*:*:* Versions 9.1 r10.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r11.0:*:*:*:*:*:* Versions 9.1 r11.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r2.0:*:*:*:*:*:* Versions 9.1 r2.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r3.0:*:*:*:*:*:* Versions 9.1 r3.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r4.0:*:*:*:*:*:* Versions 9.1 r4.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r5.0:*:*:*:*:*:* Versions 9.1 r5.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r6.0:*:*:*:*:*:* Versions 9.1 r6.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r7.0:*:*:*:*:*:* Versions 9.1 r7.0 Vulnerable ·Ivanti
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ivanti:connect_secure:9.1:r8.0:*:*:*:*:*:* | 9.1 r8.0 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:9.1:r9.0:*:*:*:*:*:* | 9.1 r9.0 | Vulnerable | Ivanti |
| cpe:2.3:a:pulsesecure:pulse_connect_secure:*:*:*:*:*:*:*:* | before 9.1 | Vulnerable | Pulse Secure |
- cpe:2.3:a:ivanti:connect_secure:9.1:r8.0:*:*:*:*:*:* Versions 9.1 r8.0 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:9.1:r9.0:*:*:*:*:*:* Versions 9.1 r9.0 Vulnerable ·Ivanti
- cpe:2.3:a:pulsesecure:pulse_connect_secure:*:*:*:*:*:*:*:* Versions before 9.1 Vulnerable ·Pulse Secure
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-22936
- 2026-10-03 Alias added: GHSA-5vfj-4g27-37g8
References
Sources
- CVE-2021-22936 · CVE Program
- CVE-2021-22936 · NVD
- FIRST EPSS
- GHSA-5vfj-4g27-37g8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences