Deserialization of untrusted data in topthink/framework
Priority MEDIUM 46CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
The package topthink/framework before 6.0.12 are vulnerable to Deserialization of Untrusted Data due to insecure unserialize method in the Driver class.
Why it matters now
EPSS 0.01765 78th percentileScored 2026-11-07
Fix Fixed topthink/framework: 6.0.12topthink/framework (Packagist): 6.0.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | topthink/framework | before 6.0.12 | 6.0.12 | Patch available | CNA |
| — | topthink/framework (Packagist) | before 6.0.12 | 6.0.12 | Patch available | GHSA-3fpv-54ff-wqfj |
- topthink/framework Vendor— Affected before 6.0.12 Fixed in 6.0.12 Patch available CNA
- topthink/framework (Packagist) Vendor— Affected before 6.0.12 Fixed in 6.0.12 Patch available GHSA-3fpv-54ff-wqfj
Remediation
- Fix · CNA topthink/framework Fixed in 6.0.12
- Fix · GHSA-3fpv-54ff-wqfj topthink/framework (Packagist) Fixed in 6.0.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-23592
- 2026-10-03 Alias added: GHSA-3fpv-54ff-wqfj
References
More Thinkphp vulnerabilities
- TI-2019-06557 ThinkPHP before 3.2.4, as used in Open Source BMS v1.1.1 and other products, allows… KEVCVSS 3.1HIGH 8.8
- TI-2025-32227 An issue in thinkphp3 v.3.2.5 allows a remote attacker to execute arbitrary code via the index.php component CVSS 3.1CRITICAL 9.8
- TI-2025-32226 An issue in thinkphp v.5.1 allows a remote attacker to execute arbitrary code via the routecheck function CVSS 3.1CRITICAL 9.8
- TI-2024-32271 A deserialization vulnerability in the component \controller\Index.php of Thinkphp v6.1.3… CVSS 3.1CRITICAL 9.8
- TI-2024-30031 A deserialization vulnerability in Thinkphp v6.1.3 to v8.0.4 allows attackers to execute arbitrary code. CVSS 3.1CRITICAL 9.8
- TI-2022-23758 ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-23592 · CVE Program
- CVE-2021-23592 · NVD
- FIRST EPSS
- GHSA-3fpv-54ff-wqfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences