Constant Contact Forms < 1.8.8 - Multiple Authenticated Stored XSS
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Unvalidated input and lack of output encoding in the Constant Contact Forms WordPress plugin, versions before 1.8.8, lead to multiple Stored Cross-Site Scripting vulnerabilities, which allowed high-privileged user (Editor+) to inject arbitrary JavaScript code or HTML in posts where the malicious form is embed.
Why it matters now
EPSS 0.00654 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Constant Contact Forms (Unknown): 1.8.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Constant Contact Forms | 1.8.8 to before 1.8.8 | 1.8.8 | Patch available | CNA |
- Constant Contact Forms VendorUnknown Affected 1.8.8 to before 1.8.8 Fixed in 1.8.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:constantcontact:constant_contact_forms:*:*:*:*:*:wordpress:*:* | before 1.8.8 | Vulnerable | Constant Contact |
- cpe:2.3:a:constantcontact:constant_contact_forms:*:*:*:*:*:wordpress:*:* Versions before 1.8.8 Vulnerable ·Constant Contact
Remediation
- Fix · CNA Constant Contact Forms (Unknown) Fixed in 1.8.8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24134
- 2026-10-03 Alias added: GHSA-5gq5-98jg-gqqf
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Constant Contact Forms vulnerabilities
- TI-2023-28636 WordPress Constant Contact Forms Plugin <= 2.4.2 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
Sources
- CVE-2021-24134 · CVE Program
- CVE-2021-24134 · NVD
- FIRST EPSS
- GHSA-5gq5-98jg-gqqf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences