Ajax Load More < 5.3.2 - Authenticated SQL Injection
Priority LOW 34CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
Unvalidated input in the Ajax Load More WordPress plugin, versions before 5.3.2, lead to SQL Injection in POST /wp-admin/admin-ajax.php with param repeater=' or sleep(5)#&type=test.
Why it matters now
EPSS 0.01205 68th percentileScored 2026-11-07
Fix Fixed Ajax Load More (Unknown): 5.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ajax Load More | 5.3.2 to before 5.3.2 | 5.3.2 | Patch available | CNA |
- Ajax Load More VendorUnknown Affected 5.3.2 to before 5.3.2 Fixed in 5.3.2 Patch available CNA
Remediation
- Fix · CNA Ajax Load More (Unknown) Fixed in 5.3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24140
- 2026-10-03 Alias added: GHSA-w9hc-cq6j-8gqw
References
More dcooney Ajax Load More vulnerabilities
- TI-2015-08068 Ajax Load More < 2.8.1.2 - Subscriber+ File Upload & Deletion CVSS 3.1HIGH 8.8
- TI-2022-04081 WordPress Infinite Scroll - Ajax Load More < 5.6.0.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-02721 WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Authenticated (Admin+) Arbitrary File Read CVSS 3.1MEDIUM 4.9
- TI-2022-02247 WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Cross-Site Request Forgery to PHAR Deserialization CVSS 3.1HIGH 8.8
- TI-2024-07885 Cross-site scripting in dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load CVSS 3.1MEDIUM 6.4
- TI-2025-30127 WordPress Ajax Load More plugin <= 7.3.1.2 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24140 · CVE Program
- CVE-2021-24140 · NVD
- FIRST EPSS
- GHSA-w9hc-cq6j-8gqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences