Advanced Database Cleaner < 3.0.2 - Authenticated SQL injection
Priority LOW 34CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
Unvaludated input in the Advanced Database Cleaner plugin, versions before 3.0.2, lead to SQL injection allowing high privilege users (admin+) to perform SQL attacks.
Why it matters now
EPSS 0.01205 68th percentileScored 2026-11-07
Fix Fixed Advanced Database Cleaner (Unknown): 3.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Advanced Database Cleaner | 3.0.2 to before 3.0.2 | 3.0.2 | Patch available | CNA |
- Advanced Database Cleaner VendorUnknown Affected 3.0.2 to before 3.0.2 Fixed in 3.0.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sigmaplugin:advanced_database_cleaner:*:*:*:*:*:wordpress:*:* | before 3.0.2 | Vulnerable | SigmaPlugin |
- cpe:2.3:a:sigmaplugin:advanced_database_cleaner:*:*:*:*:*:wordpress:*:* Versions before 3.0.2 Vulnerable ·SigmaPlugin
Remediation
- Fix · CNA Advanced Database Cleaner (Unknown) Fixed in 3.0.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24141
- 2026-10-03 Alias added: GHSA-6h67-c8r4-fr78
References
More SigmaPlugin Advanced Database Cleaner vulnerabilities
- TI-2022-23159 WordPress Advanced Database Cleaner Plugin <= 3.1.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-00615 Advanced Database Cleaner <= 3.1.3 - Authenticated(Administrator+) PHP Object Injection via process_bulk_action CVSS 3.1HIGH 7.2
- TI-2023-27174 WordPress Advanced Database Cleaner Plugin <= 3.1.2 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2022-02011 Advanced Database Cleaner < 3.1.1 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2021-07201 Advanced Database Cleaner < 3.0.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-24141 · CVE Program
- CVE-2021-24141 · NVD
- FIRST EPSS
- GHSA-6h67-c8r4-fr78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences