Read the docs
TI-2022-02011 Aliases CVE-2022-2173GHSA-h52v-6ppv-4xw2

Advanced Database Cleaner < 3.1.1 - Reflected Cross-Site Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Advanced Database Cleaner WordPress plugin before 3.1.1 does not escape numerous generated URLs before outputting them back in href attributes of admin dashboard pages, leading to Reflected Cross-Site Scripting

Why it matters now

EPSS 0.00788 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Database Cleaner (Unknown): 3.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAdvanced Database Cleaner3.1.1 to before 3.1.13.1.1Patch availableCNA
  • Advanced Database Cleaner VendorUnknown Affected 3.1.1 to before 3.1.1 Fixed in 3.1.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sigmaplugin:advanced_database_cleaner:*:*:*:*:*:wordpress:*:*before 3.1.1VulnerableSigmaPlugin
  • cpe:2.3:a:sigmaplugin:advanced_database_cleaner:*:*:*:*:*:wordpress:*:* Versions before 3.1.1 Vulnerable ·SigmaPlugin

Remediation

  • Fix · CNA Advanced Database Cleaner (Unknown) Fixed in 3.1.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-2173
  2. 2026-10-03 Alias added: GHSA-h52v-6ppv-4xw2

References

  • TI-2022-23159 WordPress Advanced Database Cleaner Plugin <= 3.1.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-00615 Advanced Database Cleaner <= 3.1.3 - Authenticated(Administrator+) PHP Object Injection via process_bulk_action CVSS 3.1HIGH 7.2
  • TI-2023-27174 WordPress Advanced Database Cleaner Plugin <= 3.1.2 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
  • TI-2021-06433 Advanced Database Cleaner < 3.0.2 - Authenticated SQL injection CVSS 3.1HIGH 7.2
  • TI-2021-07201 Advanced Database Cleaner < 3.0.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1

Sources