Read the docs
TI-2021-06499 Aliases CVE-2021-24207GHSA-x6pg-q78v-fw5w

WP Page Builder < 1.2.4 - Insecure default configuration Allows Subscribers Editing Access to Posts

Priority LOW 21CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass, Privilege escalation
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863 and CWE-269.

Summary

By default, the WP Page Builder WordPress plugin before 1.2.4 allows subscriber-level users to edit and make changes to any and all posts pages - user roles must be specifically blocked from editing posts and pages.

Why it matters now

EPSS 0.00689 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Page Builder (Unknown): 1.2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Page Builder1.2.4 to before 1.2.41.2.4Patch availableCNA
  • WP Page Builder VendorUnknown Affected 1.2.4 to before 1.2.4 Fixed in 1.2.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themeum:wp_page_builder:*:*:*:*:*:wordpress:*:*before 1.2.4Vulnerablethemeum
  • cpe:2.3:a:themeum:wp_page_builder:*:*:*:*:*:wordpress:*:* Versions before 1.2.4 Vulnerable ·themeum

Remediation

  • Fix · CNA WP Page Builder (Unknown) Fixed in 1.2.4

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    WP Page Builder 1.2.4

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2021-06500 WP Page Builder < 1.2.4 - Multiple Stored Cross-Site scripting (XSS)Priority LOW 25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24207
  2. 2026-10-03 Alias added: GHSA-x6pg-q78v-fw5w

References

  • TI-2022-03510 WP Page Builder <= 1.2.8 - Admin+ Stored Cross-Site CVSS 3.1MEDIUM 4.8
  • TI-2022-19506 WordPress WP Page Builder plugin <= 1.2.6 - Multiple Auth. Stored Cross-Site Scripting (XSS) vulnerabilities CVSS 3.1MEDIUM 5.4
  • TI-2021-06500 WP Page Builder < 1.2.4 - Multiple Stored Cross-Site scripting (XSS) CVSS 3.1MEDIUM 5.4

Sources