Patreon WordPress < 1.7.2 - Reflected XSS on patreon_save_attachment_patreon_level AJAX action
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Jetpack Scan team identified a Reflected Cross-Site Scripting via the patreon_save_attachment_patreon_level AJAX action of the Patreon WordPress plugin before 1.7.2. This AJAX hook is used to update the pledge level required by Patreon subscribers to access a given attachment. This action is accessible for user accounts with the ‘manage_options’ privilege (i.e.., only administrators). Unfortunately, one of the parameters used in this AJAX endpoint is not sanitized before being printed back to the user, so the risk it represents is the same as the previous XSS vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Patreon WordPress | 1.7.2 to before 1.7.2 | 1.7.2 | Patch available | CNA |
- Patreon WordPress VendorUnknown Affected 1.7.2 to before 1.7.2 Fixed in 1.7.2 Patch available CNA
Remediation
- Fix · CNA Patreon WordPress (Unknown) Fixed in 1.7.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Patreon WordPress 1.7.2
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2021-06520 Patreon WordPress < 1.7.2 - Reflected XSS on Login FormPriority MEDIUM 45
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24229
- 2026-10-03 Alias added: GHSA-224j-3632-5gqr
References
More Patreon Wordpress vulnerabilities
- TI-2018-14946 The patreon-connect plugin before 1.2.2 for WordPress has Object Injection. CVSS 3.0CRITICAL 9.8
- TI-2021-06520 Patreon WordPress < 1.7.2 - Reflected XSS on Login Form CVSS 3.1CRITICAL 9.6
- TI-2021-06519 Patreon WordPress < 1.7.0 - Unauthenticated Local File Disclosure CVSS 3.1HIGH 7.5
- TI-2023-21745 WordPress Patreon WordPress Plugin <= 1.8.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-06522 Patreon WordPress < 1.7.0 - CSRF to Overwrite/Create User Meta CVSS 3.1HIGH 8.1
- TI-2021-06523 Patreon WordPress < 1.7.0 - CSRF to Disconnect Sites From Patreon CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24229 · CVE Program
- CVE-2021-24229 · NVD
- FIRST EPSS
- GHSA-224j-3632-5gqr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences