Patreon WordPress < 1.7.0 - CSRF to Overwrite/Create User Meta
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Jetpack Scan team identified a Cross-Site Request Forgery vulnerability in the Patreon WordPress plugin before 1.7.0, allowing attackers to make a logged in user overwrite or create arbitrary user metadata on the victim’s account once visited. If exploited, this bug can be used to overwrite the “wp_capabilities” meta, which contains the affected user account’s roles and privileges. Doing this would essentially lock them out of the site, blocking them from accessing paid content.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Patreon WordPress | 1.7.0 to before 1.7.0 | 1.7.0 | Patch available | CNA |
- Patreon WordPress VendorUnknown Affected 1.7.0 to before 1.7.0 Fixed in 1.7.0 Patch available CNA
Remediation
- Fix · CNA Patreon WordPress (Unknown) Fixed in 1.7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Patreon WordPress 1.7.0
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-06519 Patreon WordPress < 1.7.0 - Unauthenticated Local File DisclosurePriority MEDIUM 42
- TI-2021-06523 Patreon WordPress < 1.7.0 - CSRF to Disconnect Sites From PatreonPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24230
- 2026-10-03 Alias added: GHSA-9pr2-6qr7-7436
References
More Patreon Wordpress vulnerabilities
- TI-2018-14946 The patreon-connect plugin before 1.2.2 for WordPress has Object Injection. CVSS 3.0CRITICAL 9.8
- TI-2021-06521 Patreon WordPress < 1.7.2 - Reflected XSS on patreon_save_attachment_patreon_level AJAX action CVSS 3.1CRITICAL 9.6
- TI-2021-06520 Patreon WordPress < 1.7.2 - Reflected XSS on Login Form CVSS 3.1CRITICAL 9.6
- TI-2021-06519 Patreon WordPress < 1.7.0 - Unauthenticated Local File Disclosure CVSS 3.1HIGH 7.5
- TI-2023-21745 WordPress Patreon WordPress Plugin <= 1.8.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-06523 Patreon WordPress < 1.7.0 - CSRF to Disconnect Sites From Patreon CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24230 · CVE Program
- CVE-2021-24230 · NVD
- FIRST EPSS
- GHSA-9pr2-6qr7-7436 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences