ElementsKit and ElementsKit Pro < 2.2.0 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Elements Kit Lite and Elements Kit Pro WordPress Plugins before 2.2.0 have a number of widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.00626 50th percentileScored 2026-11-07
Fix Fixed Elements Kit Lite (Wpmet): 2.2.0Elements Kit Pro (Wpmet): 2.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Elements Kit Lite (Wpmet) Fixed in 2.2.0
- Fix · CNA Elements Kit Pro (Wpmet) Fixed in 2.2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24258
- 2026-10-03 Alias added: GHSA-487m-63p5-88hq
- 2026-10-31 EPSS moved to the 50th–90th percentile
References
More roxnor Elements Kit Elementor Addons vulnerabilities
- TI-2024-01903 ElementsKit Elementor addons <= 3.0.6 - Authenticated (Contributor+) Local File Inclusion in render_raw CVSS 3.1HIGH 8.8
- TI-2024-03264 ElementsKit Elementor addons <= 3.1.0 - Authenticated (Contributor+) Local File Inclusion via Onepage Scroll Module CVSS 3.1HIGH 8.8
- TI-2023-06033 ElementsKit Lite <= 3.0.3 - Unauthenticated Sensitive Information Exposure CVSS 3.1MEDIUM 5.3
- TI-2024-24770 WordPress ElementsKit Lite plugin <= 3.1.4 - Unauthenticated Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-05991 ElementsKit Elementor addons <= 3.2.0 - Unauthenticated Information Exposure via ekit_widgetarea_content Function CVSS 3.1MEDIUM 5.3
- TI-2024-21392 WordPress ElementsKit Elementor addons plugin <= 3.0.6 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24258 · CVE Program
- CVE-2021-24258 · NVD
- FIRST EPSS
- GHSA-487m-63p5-88hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences