Elementor Addon Elements < 1.11.2 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The “Elementor Addon Elements” WordPress Plugin before 1.11.2 has several widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.
Why it matters now
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Elementor Addon Elements (Unknown): 1.11.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Elementor Addon Elements | 1.11.2 to before 1.11.2 | 1.11.2 | Patch available | CNA |
- Elementor Addon Elements VendorUnknown Affected 1.11.2 to before 1.11.2 Fixed in 1.11.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webtechstreet:elementor_addon_elements:*:*:*:*:*:wordpress:*:* | before 1.11.2 | Vulnerable | webtechstreet |
- cpe:2.3:a:webtechstreet:elementor_addon_elements:*:*:*:*:*:wordpress:*:* Versions before 1.11.2 Vulnerable ·webtechstreet
Remediation
- Fix · CNA Elementor Addon Elements (Unknown) Fixed in 1.11.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24259
- 2026-10-03 Alias added: GHSA-9phq-v8w7-m26h
References
More webtechstreet Elementor Addon Elements vulnerabilities
- TI-2024-01266 Elementor Addon Elements <= 1.12.12 - Directory Traversal to Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2024-01328 Elementor Addon Elements <= 1.12.12 - Authenticated(Contributor+) Stored Cross-Site Scripting via Modal Popup effet CVSS 3.1MEDIUM 6.4
- TI-2024-31679 WordPress Elementor Addon Elements plugin <= 1.13.6 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-20148 WordPress Elementor Addon Elements plugin <= 1.13.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-19281 WordPress Elementor Addon Elements plugin <= 1.12.10 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-06594 Elementor Addon Elements <= 1.13.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24259 · CVE Program
- CVE-2021-24259 · NVD
- FIRST EPSS
- GHSA-9phq-v8w7-m26h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences