Read the docs
TI-2021-06567 Aliases CVE-2021-24275GHSA-xh33-9j66-fv2x

Popup by Supsystic < 1.10.5 - Reflected Cross-Site scripting (XSS)

Priority MEDIUM 45CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Popup by Supsystic WordPress plugin before 1.10.5 did not sanitise the tab parameter of its options page before outputting it in an attribute, leading to a reflected Cross-Site Scripting issue

Why it matters now

EPSS 0.18165 97th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Popup by Supsystic (Supsystic): 1.10.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SupsysticPopup by Supsystic1.10.5 to before 1.10.51.10.5Patch availableCNA
  • Popup by Supsystic VendorSupsystic Affected 1.10.5 to before 1.10.5 Fixed in 1.10.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:supsystic:popup:*:*:*:*:*:wordpress:*:*before 1.10.5VulnerableSupsystic
  • cpe:2.3:a:supsystic:popup:*:*:*:*:*:wordpress:*:* Versions before 1.10.5 Vulnerable ·Supsystic

Remediation

  • Fix · CNA Popup by Supsystic (Supsystic) Fixed in 1.10.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24275
  2. 2026-10-03 Alias added: GHSA-xh33-9j66-fv2x

References

  • TI-2023-02984 Supsystic Popup < 1.10.19 - Prototype Pollution CVSS 3.1CRITICAL 9.8
  • TI-2023-28011 WordPress Popup by Supsystic plugin <= 1.10.19 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2017-14131 Supsystic Popup Plugin cross-site request forgery CVSS 3.1MEDIUM 4.3
  • TI-2023-20889 WordPress Popup by Supsystic plugin <= 1.10.19 - Broken Access Control Vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2024-35105 WordPress Popup by Supsystic plugin <= 1.10.29 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.1
  • TI-2016-08953 The popup-by-supsystic plugin before 1.7.9 for WordPress has CSRF. CVSS 3.0HIGH 8.8
See all 9 →

Sources