Autoptimize < 2.8.4 - Authenticated Stored Cross-Site Scripting (XSS)
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Autoptimize WordPress plugin before 2.8.4 was missing proper escaping and sanitisation in some of its settings, allowing high privilege users to set XSS payloads in them, leading to stored Cross-Site Scripting issues
Why it matters now
EPSS 0.00626 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Autoptimize (Unknown): 2.8.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Autoptimize | 2.8.4 to before 2.8.4 | 2.8.4 | Patch available | CNA |
- Autoptimize VendorUnknown Affected 2.8.4 to before 2.8.4 Fixed in 2.8.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:autoptimize:autoptimize:*:*:*:*:*:wordpress:*:* | before 2.8.4 | Vulnerable | Autoptimize |
- cpe:2.3:a:autoptimize:autoptimize:*:*:*:*:*:wordpress:*:* Versions before 2.8.4 Vulnerable ·Autoptimize
Remediation
- Fix · CNA Autoptimize (Unknown) Fixed in 2.8.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24332
- 2026-10-03 Alias added: GHSA-5fgw-wpxm-vqq2
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More Autoptimize vulnerabilities
- TI-2023-01988 Autoptimize < 3.1.7 - Admin+ Stored Cross-Site Scripting via Settings Import CVSS 3.1MEDIUM 4.8
- TI-2021-06668 Autoptimize < 2.7.8 - Arbitrary File Upload via "Import Settings" CVSS 3.1CRITICAL 9.8
- TI-2020-15253 The ao_ccss_import AJAX call in Autoptimize Wordpress Plugin 2.7.6 does not ensure that… CVSS 3.1HIGH 7.2
- TI-2021-06669 Autoptimize < 2.7.8 - Race Condition leading to RCE CVSS 3.1HIGH 8.1
- TI-2022-02436 Autoptimize < 3.1.1 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2021-06670 Autoptimize < 2.7.8 - Authenticated Stored XSS via File Upload CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24332 · CVE Program
- CVE-2021-24332 · NVD
- FIRST EPSS
- GHSA-5fgw-wpxm-vqq2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences