Autoptimize < 3.1.7 - Admin+ Stored Cross-Site Scripting via Settings Import
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Autoptimize WordPress plugin before 3.1.7 does not sanitise and escape the settings imported from a previous export, allowing high privileged users (such as an administrator) to inject arbitrary javascript into the admin panel, even when the unfiltered_html capability is disabled, such as in a multisite setup.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Autoptimize (Unknown): 3.1.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Autoptimize | before 3.1.7 | 3.1.7 | Patch available | CNA |
- Autoptimize VendorUnknown Affected before 3.1.7 Fixed in 3.1.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:autoptimize:autoptimize:*:*:*:*:*:wordpress:*:* | before 3.1.7 | Vulnerable | Autoptimize |
- cpe:2.3:a:autoptimize:autoptimize:*:*:*:*:*:wordpress:*:* Versions before 3.1.7 Vulnerable ·Autoptimize
Remediation
- Fix · CNA Autoptimize (Unknown) Fixed in 3.1.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2113
- 2026-10-03 Alias added: GHSA-562q-c576-2qqf
References
More Autoptimize vulnerabilities
- TI-2021-06668 Autoptimize < 2.7.8 - Arbitrary File Upload via "Import Settings" CVSS 3.1CRITICAL 9.8
- TI-2020-15253 The ao_ccss_import AJAX call in Autoptimize Wordpress Plugin 2.7.6 does not ensure that… CVSS 3.1HIGH 7.2
- TI-2021-06669 Autoptimize < 2.7.8 - Race Condition leading to RCE CVSS 3.1HIGH 8.1
- TI-2022-02436 Autoptimize < 3.1.1 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2021-06670 Autoptimize < 2.7.8 - Authenticated Stored XSS via File Upload CVSS 3.1MEDIUM 4.8
- TI-2021-06624 Autoptimize < 2.8.4 - Authenticated Stored Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-2113 · CVE Program
- CVE-2023-2113 · NVD
- FIRST EPSS
- GHSA-562q-c576-2qqf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences