Read the docs
TI-2021-06704 Aliases CVE-2021-24412GHSA-cq83-pmg7-mjwj

Html5 Audio Player < 2.1.3 - Contributor+ Stored Cross-Site Scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Html5 Audio Player – Audio Player for WordPress plugin before 2.1.3 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode

Why it matters now

EPSS 0.0065 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Html5 Audio Player – Audio Player for WordPress (Unknown): 2.1.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHtml5 Audio Player – Audio Player for WordPress2.1.3 to before 2.1.32.1.3Patch availableCNA
  • Html5 Audio Player – Audio Player for WordPress VendorUnknown Affected 2.1.3 to before 2.1.3 Fixed in 2.1.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:bplugins:html5_audio_player:*:*:*:*:*:wordpress:*:*before 2.1.3VulnerablebPlugins
  • cpe:2.3:a:bplugins:html5_audio_player:*:*:*:*:*:wordpress:*:* Versions before 2.1.3 Vulnerable ·bPlugins

Remediation

  • Fix · CNA Html5 Audio Player – Audio Player for WordPress (Unknown) Fixed in 2.1.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24412
  2. 2026-10-03 Alias added: GHSA-cq83-pmg7-mjwj
  3. 2026-10-16 EPSS moved to the 50th–90th percentile

References

  • TI-2023-00164 Html5 Audio Player < 2.1.12 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-24949 WordPress HTML5 Audio Player plugin <= 2.2.23 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources