Easy Twitter Feed < 1.2 - Contributor+ Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Easy Twitter Feed WordPress plugin before 1.2 does not sanitise or validate the parameters from its shortcode, allowing users with a role as low as contributor to set Cross-Site Scripting payload in them which will be triggered in the page/s with the embed malicious shortcode
Why it matters now
EPSS 0.0065 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Easy Twitter Feed (Unknown): 1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Easy Twitter Feed | 1.2 to before 1.2 | 1.2 | Patch available | CNA |
- Easy Twitter Feed VendorUnknown Affected 1.2 to before 1.2 Fixed in 1.2 Patch available CNA
Remediation
- Fix · CNA Easy Twitter Feed (Unknown) Fixed in 1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24413
- 2026-10-03 Alias added: GHSA-hx6c-g4wq-3xwx
- 2026-10-16 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2021-24413 · CVE Program
- CVE-2021-24413 · NVD
- FIRST EPSS
- GHSA-hx6c-g4wq-3xwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences