UpdraftPlus < 1.16.59 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The UpdraftPlus WordPress Backup Plugin WordPress plugin before 1.6.59 does not sanitise its updraft_service settings, allowing high privilege users to set malicious JavaScript payload in it and leading to a Stored Cross-Site Scripting issue
Why it matters now
EPSS 0.00614 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed UpdraftPlus WordPress Backup Plugin (Unknown): 1.6.59
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | UpdraftPlus WordPress Backup Plugin | 1.6.59 to before 1.6.59 | 1.6.59 | Patch available | CNA |
- UpdraftPlus WordPress Backup Plugin VendorUnknown Affected 1.6.59 to before 1.6.59 Fixed in 1.6.59 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:updraftplus:updraftplus:*:*:*:*:*:wordpress:*:* | before 1.16.59 | Vulnerable | UpdraftPlus |
- cpe:2.3:a:updraftplus:updraftplus:*:*:*:*:*:wordpress:*:* Versions before 1.16.59 Vulnerable ·UpdraftPlus
Remediation
- Fix · CNA UpdraftPlus WordPress Backup Plugin (Unknown) Fixed in 1.6.59
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24423
- 2026-10-03 Alias added: GHSA-4v9q-rjxq-3952
References
More Updraftplus vulnerabilities
- TI-2021-07300 UpdraftPlus < 1.16.66 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-12417 The UpdraftPlus plugin through 1.13.12 for WordPress allows remote PHP code execution… CVSS 3.0HIGH 8.1
- TI-2022-00770 UpdraftPlus < 1.22.9 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-12416 The UpdraftPlus plugin through 1.13.12 for WordPress has SSRF in the updraft_ajax_handler… CVSS 3.0HIGH 8.1
- TI-2022-00550 UpdraftPlus Free < 1.22.3 & Premium < 2.22.3 - Subscriber+ Backup Download CVSS 3.1MEDIUM 6.5
- TI-2023-16148 WordPress UpdraftPlus Plugin <= 1.23.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 7.1
Sources
- CVE-2021-24423 · CVE Program
- CVE-2021-24423 · NVD
- FIRST EPSS
- GHSA-4v9q-rjxq-3952 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences