YouTube Embed, Playlist and Popup < 2.3.9 - Contributor+ Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The YouTube Embed, Playlist and Popup by WpDevArt WordPress plugin before 2.3.9 did not escape, validate or sanitise some of its shortcode options, available to users with a role as low as Contributor, leading to an authenticated Stored Cross-Site Scripting issue.
Why it matters now
EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed YouTube Embed, Playlist and Popup by WpDevArt (Unknown): 2.3.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | YouTube Embed, Playlist and Popup by WpDevArt | 2.3.9 to before 2.3.9 | 2.3.9 | Patch available | CNA |
- YouTube Embed, Playlist and Popup by WpDevArt VendorUnknown Affected 2.3.9 to before 2.3.9 Fixed in 2.3.9 Patch available CNA
Remediation
- Fix · CNA YouTube Embed, Playlist and Popup by WpDevArt (Unknown) Fixed in 2.3.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24464
- 2026-10-03 Alias added: GHSA-jhv7-95mg-63jj
References
More wpdevart Youtube Embed, Playlist And Popup vulnerabilities
- TI-2023-09789 WordPress YouTube Embed, Playlist and Popup by WpDevArt Plugin <= 2.6.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2021-24464 · CVE Program
- CVE-2021-24464 · NVD
- FIRST EPSS
- GHSA-jhv7-95mg-63jj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences