Form Builder < 1.9.8.4 - Authenticated Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Form Builder | Create Responsive Contact Forms WordPress plugin before 1.9.8.4 does not sanitise or escape its Form Title, allowing high privilege users such as admin to set Cross-Site Scripting payload in them, even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Form Builder | Create Responsive Contact Forms (Unknown): 1.9.8.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Form Builder | Create Responsive Contact Forms | 1.9.8.4 to before 1.9.8.4 | 1.9.8.4 | Patch available | CNA |
- Form Builder | Create Responsive Contact Forms VendorUnknown Affected 1.9.8.4 to before 1.9.8.4 Fixed in 1.9.8.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:web-settler:form_builder:*:*:*:*:*:wordpress:*:* | before 1.9.8.4 | Vulnerable | Web-Settler |
- cpe:2.3:a:web-settler:form_builder:*:*:*:*:*:wordpress:*:* Versions before 1.9.8.4 Vulnerable ·Web-Settler
Remediation
- Fix · CNA Form Builder | Create Responsive Contact Forms (Unknown) Fixed in 1.9.8.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24513
- 2026-10-03 Alias added: GHSA-4c89-7wj7-fm5r
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More Web-Settler Form Builder vulnerabilities
- TI-2023-09596 WordPress Form Builder Plugin <= 1.9.9.0 is vulnerable to CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2023-09595 WordPress Form Builder Plugin <= 1.9.9.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24513 · CVE Program
- CVE-2021-24513 · NVD
- FIRST EPSS
- GHSA-4c89-7wj7-fm5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences