Maintenance < 4.03 - Authenticated Stored XSS
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Maintenance (Unknown): 4.03
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Maintenance | 4.03 to before 4.03 | 4.03 | Patch available | CNA |
- Maintenance VendorUnknown Affected 4.03 to before 4.03 Fixed in 4.03 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webfactoryltd:maintenance:*:*:*:*:*:wordpress:*:* | before 4.03 | Vulnerable | webfactory |
- cpe:2.3:a:webfactoryltd:maintenance:*:*:*:*:*:wordpress:*:* Versions before 4.03 Vulnerable ·webfactory
Remediation
- Fix · CNA Maintenance (Unknown) Fixed in 4.03
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24533
- 2026-10-03 Alias added: GHSA-w4v9-jmhm-6jw4
References
Sources
- CVE-2021-24533 · CVE Program
- CVE-2021-24533 · NVD
- FIRST EPSS
- GHSA-w4v9-jmhm-6jw4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences