WP SMS < 5.4.13 - Authenticated Stored Cross-Site Scripting
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP SMS WordPress plugin before 5.4.13 does not sanitise the "wp_group_name" parameter before outputting it back in the "Groups" page, leading to an Authenticated Stored Cross-Site Scripting issue
Why it matters now
EPSS 0.00671 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP SMS (Unknown): 5.4.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP SMS | 5.4.13 to before 5.4.13 | 5.4.13 | Patch available | CNA |
- WP SMS VendorUnknown Affected 5.4.13 to before 5.4.13 Fixed in 5.4.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:veronalabs:wp_sms:*:*:*:*:free:wordpress:*:* | before 5.4.13 | Vulnerable | VeronaLabs |
- cpe:2.3:a:veronalabs:wp_sms:*:*:*:*:free:wordpress:*:* Versions before 5.4.13 Vulnerable ·VeronaLabs
Remediation
- Fix · CNA WP SMS (Unknown) Fixed in 5.4.13
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24561
- 2026-10-03 Alias added: GHSA-3hc7-7vjp-8x77
References
More VeronaLabs Wp Sms vulnerabilities
- TI-2024-28983 WordPress WP SMS plugin <= 6.9.3 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-20180 WordPress WP SMS plugin <= 6.6.2 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2023-12179 WordPress WP SMS Plugin <= 6.0.4 is vulnerable to Sensitive Data Exposure CVSS 3.1HIGH 7.5
- TI-2024-16395 WordPress WP SMS Plugin <= 6.5.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-16008 WordPress WP SMS Plugin <= 6.1.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-17020 WordPress WP SMS plugin <= 6.3.4 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24561 · CVE Program
- CVE-2021-24561 · NVD
- FIRST EPSS
- GHSA-3hc7-7vjp-8x77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences