WooCommerce Currency Switcher < 1.3.7 - Authenticated (Low Privilege) Local File Inclusion
Priority MEDIUM 43CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WooCommerce Currency Switcher FOX WordPress plugin before 1.3.7 was vulnerable to LFI attacks via the "woocs" shortcode.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01316 70th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed FOX (Unknown): 1.3.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FOX | before 1.3.7 | 1.3.7 | Patch available | CNA |
- FOX VendorUnknown Affected before 1.3.7 Fixed in 1.3.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pluginus:fox_-_currency_switcher_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.3.7 | Vulnerable | realmag777 |
- cpe:2.3:a:pluginus:fox_-_currency_switcher_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.3.7 Vulnerable ·realmag777
Remediation
- Fix · CNA FOX (Unknown) Fixed in 1.3.7
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24566
- 2026-10-03 Alias added: GHSA-j977-qqwc-8rmm
References
More realmag777 Fox - Currency Switcher Professional For Woocommerce vulnerabilities
- TI-2022-04048 WOOCS < 1.3.9.4 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-07667 FOX – Currency Switcher Professional for WooCommerce <= 1.4.2.1 - Unauthenticated Arbitrary Shortcode Execution CVSS 3.1HIGH 7.3
- TI-2024-20184 Cross-site request forgery in realmag777 WOOCS – WooCommerce Currency Switcher CVSS 3.1HIGH 8.8
- TI-2023-27238 WordPress WOOCS – WooCommerce Currency Switcher Plugin <= 1.4.1.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-06007 Cross-site scripting in realmag777 FOX – Currency Switcher Professional for WooCommerce CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-24566 · CVE Program
- CVE-2021-24566 · NVD
- FIRST EPSS
- GHSA-j977-qqwc-8rmm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences