WOOCS < 1.3.9.4 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WOOCS WordPress plugin before 1.3.9.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00517 44th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed WOOCS (Unknown): 1.3.9.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WOOCS | before 1.3.9.4 | 1.3.9.4 | Patch available | CNA |
- WOOCS VendorUnknown Affected before 1.3.9.4 Fixed in 1.3.9.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pluginus:fox_-_currency_switcher_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.3.9.4 | Vulnerable | realmag777 |
- cpe:2.3:a:pluginus:fox_-_currency_switcher_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.3.9.4 Vulnerable ·realmag777
Remediation
- Fix · CNA WOOCS (Unknown) Fixed in 1.3.9.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4431
- 2026-10-03 Alias added: GHSA-5qjc-pfh5-rxg4
References
More realmag777 Fox - Currency Switcher Professional For Woocommerce vulnerabilities
- TI-2021-06851 WooCommerce Currency Switcher < 1.3.7 - Authenticated (Low Privilege) Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2024-07667 FOX – Currency Switcher Professional for WooCommerce <= 1.4.2.1 - Unauthenticated Arbitrary Shortcode Execution CVSS 3.1HIGH 7.3
- TI-2024-20184 Cross-site request forgery in realmag777 WOOCS – WooCommerce Currency Switcher CVSS 3.1HIGH 8.8
- TI-2023-27238 WordPress WOOCS – WooCommerce Currency Switcher Plugin <= 1.4.1.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-06007 Cross-site scripting in realmag777 FOX – Currency Switcher Professional for WooCommerce CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-4431 · CVE Program
- CVE-2022-4431 · NVD
- FIRST EPSS
- GHSA-5qjc-pfh5-rxg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences