WPFront Notification Bar < 2.1.0.08087 - Authenticated Stored XSS
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WPFront Notification Bar WordPress plugin before 2.1.0.08087 does not properly sanitise and escape its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WPFront Notification Bar (Unknown): 2.1.0.08087
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPFront Notification Bar | 2.1.0.08087 to before 2.1.0.08087 | 2.1.0.08087 | Patch available | CNA |
- WPFront Notification Bar VendorUnknown Affected 2.1.0.08087 to before 2.1.0.08087 Fixed in 2.1.0.08087 Patch available CNA
Remediation
- Fix · CNA WPFront Notification Bar (Unknown) Fixed in 2.1.0.08087
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24601
- 2026-10-03 Alias added: GHSA-mx5c-gqhr-8r8j
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
More Wpfront Notification Bar vulnerabilities
- TI-2024-00580 Cross-site scripting in syammohanm WPFront Notification Bar CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24601 · CVE Program
- CVE-2021-24601 · NVD
- FIRST EPSS
- GHSA-mx5c-gqhr-8r8j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences