Read the docs

Wpfront

Records6All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

Wpfront records in CISA KEV

No Wpfront vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

6 records

Priority LOW 29

The WPFront User Role Editor WordPress plugin before 3.2.1.11184 does not sanitise and escape the changes-saved parameter before outputting it back in the admin dashboard, leading to a Reflected Cross-Site Scripting

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00827 Published 2021-12-27 Fixed in 3.2.1.11184 CWE-79
Priority LOW 25

The WPFront Notification Bar WordPress plugin before 2.1.0.08087 does not properly sanitise and escape its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00624 Published 2021-09-06 Fixed in 2.1.0.08087 CWE-79
Priority LOW 25

The WPFront Scroll Top WordPress plugin before 2.0.6.07225 does not sanitise or escape its Image ALT setting before outputting it attributes, leading to an Authenticated Stored Cross-Site Scripting issues even when the u…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.0062 Published 2021-08-23 Fixed in 2.0.6.07225 CWE-79
Priority LOW 23

The WPFront Notification Bar WordPress plugin before 2.0.0.07176 does not sanitise or escape its Custom CSS setting, allowing high privilege users such as admin to set XSS payload in it even when the unfiltered_html capa…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00695 Published 2021-08-16 Fixed in 2.0.0.07176 CWE-79
Priority LOW 22

The WPFront Notification Bar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘wpfront-notification-bar-options[custom_class]’ parameter in all versions up to, and including, 3.3.2 due to insuffi…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.004 Published 2024-01-25 No fix listed CWE-79
Priority LOW 21

The WPFront User Role Editor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.2.1.11184 via the wpfront_user_role_editor_assign_roles_user_autocomplete AJAX act…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.0052 Published 2024-04-02 No fix listed CWE-200
Open these records in search →