Availability Calendar < 1.2.2 - Authenticated Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Availability Calendar WordPress plugin before 1.2.2 does not sanitise or escape its Category Names before outputting them in page/post where the associated shortcode is embed, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Availability Calendar (Unknown): 1.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Availability Calendar | 1.2.2 to before 1.2.2 | 1.2.2 | Patch available | CNA |
- Availability Calendar VendorUnknown Affected 1.2.2 to before 1.2.2 Fixed in 1.2.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:offshorewebmaster:availability_calendar:*:*:*:*:*:wordpress:*:* | before 1.2.2 | Vulnerable | Offshore Web Master |
- cpe:2.3:a:offshorewebmaster:availability_calendar:*:*:*:*:*:wordpress:*:* Versions before 1.2.2 Vulnerable ·Offshore Web Master
Remediation
- Fix · CNA Availability Calendar (Unknown) Fixed in 1.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24604
- 2026-10-03 Alias added: GHSA-p555-vm74-xq5v
References
More Offshore Web Master Availability Calendar vulnerabilities
- TI-2021-06889 Availability Calendar < 1.2.1 - Authenticated SQL Injection CVSS 3.1HIGH 8.8
- TI-2023-26574 WordPress Availability Calendar Plugin <= 1.2.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24604 · CVE Program
- CVE-2021-24604 · NVD
- FIRST EPSS
- GHSA-p555-vm74-xq5v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences